Setup

To control Omnisphere using the Roland System-1m, you’ll need to do the following:

  • Using a USB cable, connect the System-1m to your computer

  • Verify that your System-1m system firmware is up to date with v1.30 or higher

  • Download and install the appropriate System-1m USB driver on your computer

  • Verify that PLUG OUT on the System-1m is disabled.

  • Enable “System-1m” as a MIDI input device to Omnisphere in the host software you’re using (DAW, Standalone, etc.)

  • Activate the System-1 Hardware Profile in Omnisphere 2.5 or higher



FIRMWARE

Check the firmware (system program version) of your System-1m by holding down the LEGATO button and switching on the power. The LFO KEY TRIG button will flash. If the following four controls on the SYSTEM-1m panel display light up, then your System-1m is up to date.

  • The LFO [ Wave knob ] is illuminated.
  • The LFO [ FADE TIME ] knob is illuminated.
  • The LFO [ FILTER ] knob is illuminated.
  • The OSC 1 [ COLOR ] knob is illuminated.

If your System-1m is not up to date, access the Roland website to download and install the latest system program for the instrument.



USB DRIVER

Check to see if the necessary USB driver has already been installed by opening up Omnisphere standalone (or your preferred DAW) and verify the System-1m is on your list of MIDI inputs.

If your System-1m is not on your list of MIDI inputs, access the Roland website to download and install the latest drivers for the instrument.



MODEL SELECTION

Make sure that the PLUG-OUT button on the System-1m is not selected.



HOST CONNECTION

Open your host (DAW, Standalone, etc) and make sure the System-1m is enabled as a MIDI input device.

Omnisphere Standalone Pro Tools


OMNISPHERE SETUP

Open Omnisphere and from the header select the HW menu button:

From the drop-down menu, select “Roland System-1m” to activate that hardware profile.

Unassigned Controls

The following System-1m controls have no effect on Omnisphere:

  • Tempo Knob
  • Plug Out
  • Write
  • Pitch (Push Gate)
  • Volume

Troubleshooting

Not working? Here are some things to try: 

  • Make sure the MIDI Channel is set to Ch.1
  • Is your DAW receiving MIDI from the System-1m?

As a last resort, you can restore the Factory Settings by following the steps below. Note that this will delete all your user patches.

  • While holding down the WRITE button and press the LFO KEY TRIG button. The LFO KEY TRIG button blinks.
  • Hold WRITE, and press LFO KEY TRIG again to reset the instrument to Factory Reset

SUPPORT

Still not working? More questions?

Feel free to contact us directly and we can work with you:

Tech Support
888-870-4223 toll free
818-955-8444
Monday – Friday 10AM – 5PM Pacific Time

email: info@spectrasonics.net